const regex = /\d*\.?,?\d+|[\*\-\+\/\(\)\$]/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d*\\.?,?\\d+|[\\*\\-\\+\\\/\\(\\)\\$]', 'gi')
const str = `\$( 10 * 10.65 ) - 30
\$(10*10,65)-(30+2)
\$(10*10.0)-30
(10*10.0)-30
10 10.65 * \$ 30 -
100 + 1
1 + 1
1 1 +
8 + 8 / 4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}