use strict;
my $str = '$( 10 * 10.65 ) - 30
$(10*10,65)-(30+2)
$(10*10.0)-30
(10*10.0)-30
10 10.65 * $ 30 -
100 + 1
1 + 1
1 1 +
8 + 8 / 4';
my $regex = qr/\d*\.?,?\d+|[\*\-\+\/\(\)\$]/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}