re = /\d*\.?,?\d+|[\*\-\+\/\(\)\$]/i
str = '$( 10 * 10.65 ) - 30
$(10*10,65)-(30+2)
$(10*10.0)-30
(10*10.0)-30
10 10.65 * $ 30 -
100 + 1
1 + 1
1 1 +
8 + 8 / 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end