package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\d*\.?,?\d+|[\*\-\+\/\(\)\$]`)
var str = `$( 10 * 10.65 ) - 30
$(10*10,65)-(30+2)
$(10*10.0)-30
(10*10.0)-30
10 10.65 * $ 30 -
100 + 1
1 + 1
1 1 +
8 + 8 / 4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}