import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d*\\.?,?\\d+|[\\*\\-\\+\\/\\(\\)\\$]";
final String string = "$( 10 * 10.65 ) - 30\n"
+ "$(10*10,65)-(30+2)\n"
+ "$(10*10.0)-30\n"
+ "(10*10.0)-30\n"
+ "10 10.65 * $ 30 -\n"
+ "100 + 1\n"
+ "1 + 1\n"
+ "1 1 +\n"
+ "8 + 8 / 4";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}