import Foundation
let pattern = #"((\s*(const|let|var)\s*)(\w+)(\s*=\s*)(require\s*\(")(\w+)("\s*\)\s*;))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
const path = require ("path") ;
let path = require("path");
var path = require("path");
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$4,$7"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)