# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\s*(const|let|var)\s*)(\w+)(\s*=\s*)(require\s*\(")(\w+)("\s*\)\s*;))/$4,$7/g;t' <<< "const path = require (\"path\") ;
let path = require(\"path\");
var path = require(\"path\");"