const regex = /((\s*(const|let|var)\s*)(\w+)(\s*=\s*)(require\s*\(")(\w+)("\s*\)\s*;))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\s*(const|let|var)\\s*)(\\w+)(\\s*=\\s*)(require\\s*\\(")(\\w+)("\\s*\\)\\s*;))', 'g')
const str = `const path = require ("path") ;
let path = require("path");
var path = require("path");`;
const subst = `$4,$7`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);