using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\s*(const|let|var)\s*)(\w+)(\s*=\s*)(require\s*\("")(\w+)(""\s*\)\s*;))";
string substitution = @"$4,$7";
string input = @"const path = require (""path"") ;
let path = require(""path"");
var path = require(""path"");";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}