re = /((\s*(const|let|var)\s*)(\w+)(\s*=\s*)(require\s*\(")(\w+)("\s*\)\s*;))/
str = 'const path = require ("path") ;
let path = require("path");
var path = require("path");'
subst = '$4,$7'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result