# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\s*(const|let|var)\s*)(\w+)(\s*=\s*)(require\s*\(\")(\w+)(\"\s*\)\s*;))"
test_str = ("const path = require (\"path\") ;\n"
"let path = require(\"path\");\n"
"var path = require(\"path\");")
subst = "$4,$7"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.