// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^\s+(CREATE|ALTER|DROP)\s+(PROCEDURE|TRIGGER|VIEW)").unwrap();
let string = "
CREATE
PROCEDURE
As dgnasdjklgasbn
dadkjgha<asd
ag
adfg
adfg
ag
ag
afgad
ga
;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}