$re = '/^\s+(CREATE|ALTER|DROP)\s+(PROCEDURE|TRIGGER|VIEW)/i';
$str = '
CREATE
PROCEDURE
As dgnasdjklgasbn
dadkjgha<asd
ag
adfg
adfg
ag
ag
afgad
ga
;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);