const regex = /^\s+(CREATE|ALTER|DROP)\s+(PROCEDURE|TRIGGER|VIEW)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s+(CREATE|ALTER|DROP)\\s+(PROCEDURE|TRIGGER|VIEW)', 'gi')
const str = `
CREATE
PROCEDURE
As dgnasdjklgasbn
dadkjgha<asd
ag
adfg
adfg
ag
ag
afgad
ga
;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}