re = /^\s+(CREATE|ALTER|DROP)\s+(PROCEDURE|TRIGGER|VIEW)/i
str = '
CREATE
PROCEDURE
As dgnasdjklgasbn
dadkjgha<asd
ag
adfg
adfg
ag
ag
afgad
ga
;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end