#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^\s+(CREATE|ALTER|DROP)\s+(PROCEDURE|TRIGGER|VIEW)"
Local $sString = " " & @CRLF & _
"CREATE" & @CRLF & _
"" & @CRLF & _
" PROCEDURE" & @CRLF & _
"" & @CRLF & _
"As dgnasdjklgasbn" & @CRLF & _
"dadkjgha<asd" & @CRLF & _
"ag" & @CRLF & _
"adfg" & @CRLF & _
"adfg" & @CRLF & _
"ag" & @CRLF & _
"ag" & @CRLF & _
"afgad" & @CRLF & _
"ga" & @CRLF & _
";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")