import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s+(CREATE|ALTER|DROP)\\s+(PROCEDURE|TRIGGER|VIEW)";
final String string = " \n"
+ "CREATE\n\n"
+ " PROCEDURE\n\n"
+ "As dgnasdjklgasbn\n"
+ "dadkjgha<asd\n"
+ "ag\n"
+ "adfg\n"
+ "adfg\n"
+ "ag\n"
+ "ag\n"
+ "afgad\n"
+ "ga\n"
+ ";";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}