package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^\s+(CREATE|ALTER|DROP)\s+(PROCEDURE|TRIGGER|VIEW)`)
var str = `
CREATE
PROCEDURE
As dgnasdjklgasbn
dadkjgha<asd
ag
adfg
adfg
ag
ag
afgad
ga
;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}