import Foundation
let pattern = #"^data-(test|cy|jest).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
data-test
data-testid
data-test-id
data-cy
data-cyid
data-cy-id
data-jest
data-jestid
data-jest-id
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)