using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^data-(test|cy|jest).*$";
string substitution = @"";
string input = @"data-test
data-testid
data-test-id
data-cy
data-cyid
data-cy-id
data-jest
data-jestid
data-jest-id";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}