re = /^data-(test|cy|jest).*$/m
str = 'data-test
data-testid
data-test-id
data-cy
data-cyid
data-cy-id
data-jest
data-jestid
data-jest-id'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result