package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^data-(test|cy|jest).*$`)
var str = `data-test
data-testid
data-test-id
data-cy
data-cyid
data-cy-id
data-jest
data-jestid
data-jest-id`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}