import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^data-(test|cy|jest).*$";
final String string = "data-test\n"
+ "data-testid\n"
+ "data-test-id\n\n"
+ "data-cy\n"
+ "data-cyid\n"
+ "data-cy-id\n\n"
+ "data-jest\n"
+ "data-jestid\n"
+ "data-jest-id";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}