const regex = /^data-(test|cy|jest).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^data-(test|cy|jest).*$', 'gm')
const str = `data-test
data-testid
data-test-id
data-cy
data-cyid
data-cy-id
data-jest
data-jestid
data-jest-id`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);