$re = '/^data-(test|cy|jest).*$/m';
$str = 'data-test
data-testid
data-test-id
data-cy
data-cyid
data-cy-id
data-jest
data-jestid
data-jest-id';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;