// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?um)(<p>\s*<\/p>\s*)+").unwrap();
let string = "ssdfsdfsdf<p> </p> <p></p> <p> </p><p> </p><p> </p><p> </p>sd<p> </p>fsdfs
ssdfsdfsd<p> </p><p></p> sdfssfd dfsd
";
let substitution = "<p><br/></p>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}