use strict;
my $str = 'ssdfsdfsdf<p> </p> <p></p> <p> </p><p> </p><p> </p><p> </p>sd<p> </p>fsdfs
ssdfsdfsd<p> </p><p></p> sdfssfd dfsd
';
my $regex = qr/(<p>\s*<\/p>\s*)+/ump;
my $subst = '<p><br/></p>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";