re = /(<p>\s*<\/p>\s*)+/m
str = 'ssdfsdfsdf<p> </p> <p></p> <p> </p><p> </p><p> </p><p> </p>sd<p> </p>fsdfs
ssdfsdfsd<p> </p><p></p> sdfssfd dfsd
'
subst = '<p><br/></p>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result