import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<p>\\s*<\\/p>\\s*)+";
final String string = "ssdfsdfsdf<p> </p> <p></p> <p> </p><p> </p><p> </p><p> </p>sd<p> </p>fsdfs\n"
+ "ssdfsdfsd<p> </p><p></p> sdfssfd dfsd\n";
final String subst = "<p><br/></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}