# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<p>\s*<\/p>\s*)+"
test_str = ("ssdfsdfsdf<p> </p> <p></p> <p> </p><p> </p><p> </p><p> </p>sd<p> </p>fsdfs\n"
"ssdfsdfsd<p> </p><p></p> sdfssfd dfsd\n")
subst = "<p><br/></p>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.UNICODE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.