import Foundation
let pattern = #"time\s(\w+\s*\{\s\n(\s{2,8}\w+\s\w+\s.+\n){1,2}\})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ####"""
### ACL de tiempo.
## ¿Son estos los horarios que necesita?
time laboral {
weekly mtwhf 07:15 - 12:29
weekly mtwhf 13:15 - 16:00
}
time almuerzo{
weekly mtwhf 12:30 - 13:14
}
time noche {
weekly mtwhf 15:45 - 23:55
weekly mtwhf 00:01 - 07:14
}
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)