re = /time\s(\w+\s*\{\s\n(\s{2,8}\w+\s\w+\s.+\n){1,2}\})/
str = '### ACL de tiempo.
## ¿Son estos los horarios que necesita?
time laboral {
weekly mtwhf 07:15 - 12:29
weekly mtwhf 13:15 - 16:00
}
time almuerzo{
weekly mtwhf 12:30 - 13:14
}
time noche {
weekly mtwhf 15:45 - 23:55
weekly mtwhf 00:01 - 07:14
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end