// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"time\s(\w+\s*\{\s\n(\s{2,8}\w+\s\w+\s.+\n){1,2}\})").unwrap();
let string = "### ACL de tiempo.
## ¿Son estos los horarios que necesita?
time laboral {
weekly mtwhf 07:15 - 12:29
weekly mtwhf 13:15 - 16:00
}
time almuerzo{
weekly mtwhf 12:30 - 13:14
}
time noche {
weekly mtwhf 15:45 - 23:55
weekly mtwhf 00:01 - 07:14
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}