# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"time\s(\w+\s*\{\s\n(\s{2,8}\w+\s\w+\s.+\n){1,2}\})"
test_str = ("### ACL de tiempo. \n"
"## ¿Son estos los horarios que necesita? \n"
"time laboral { \n"
" weekly mtwhf 07:15 - 12:29 \n"
" weekly mtwhf 13:15 - 16:00 \n"
"} \n"
" \n"
"time almuerzo{ \n"
" weekly mtwhf 12:30 - 13:14 \n"
"} \n"
" \n"
"time noche { \n"
" weekly mtwhf 15:45 - 23:55 \n"
" weekly mtwhf 00:01 - 07:14 \n"
"} \n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.