import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "time\\s(\\w+\\s*\\{\\s\\n(\\s{2,8}\\w+\\s\\w+\\s.+\\n){1,2}\\})";
final String string = "### ACL de tiempo. \n"
+ "## ¿Son estos los horarios que necesita? \n"
+ "time laboral { \n"
+ " weekly mtwhf 07:15 - 12:29 \n"
+ " weekly mtwhf 13:15 - 16:00 \n"
+ "} \n"
+ " \n"
+ "time almuerzo{ \n"
+ " weekly mtwhf 12:30 - 13:14 \n"
+ "} \n"
+ " \n"
+ "time noche { \n"
+ " weekly mtwhf 15:45 - 23:55 \n"
+ " weekly mtwhf 00:01 - 07:14 \n"
+ "} \n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}