using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"time\s(\w+\s*\{\s\n(\s{2,8}\w+\s\w+\s.+\n){1,2}\})";
string input = @"### ACL de tiempo.
## ¿Son estos los horarios que necesita?
time laboral {
weekly mtwhf 07:15 - 12:29
weekly mtwhf 13:15 - 16:00
}
time almuerzo{
weekly mtwhf 12:30 - 13:14
}
time noche {
weekly mtwhf 15:45 - 23:55
weekly mtwhf 00:01 - 07:14
}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}