import Foundation
let pattern = #"stone *variant=([^\s]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
setblock ~ ~ ~ minecraft:stone variant=granite aadsdasdsad
execute @e[type=ArmorStand] ~ ~ ~ setblock ~ ~ ~ minecraft:stone variant=granite
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"stone 1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)