using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"stone *variant=([^\s]*)";
string substitution = @"stone 1";
string input = @"setblock ~ ~ ~ minecraft:stone variant=granite aadsdasdsad
execute @e[type=ArmorStand] ~ ~ ~ setblock ~ ~ ~ minecraft:stone variant=granite
";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}