$re = '/stone *variant=([^\s]*)/i';
$str = 'setblock ~ ~ ~ minecraft:stone variant=granite aadsdasdsad
execute @e[type=ArmorStand] ~ ~ ~ setblock ~ ~ ~ minecraft:stone variant=granite
';
$subst = "stone 1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;