package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)stone *variant=([^\s]*)`)
var str = `setblock ~ ~ ~ minecraft:stone variant=granite aadsdasdsad
execute @e[type=ArmorStand] ~ ~ ~ setblock ~ ~ ~ minecraft:stone variant=granite
`
var substitution = "stone 1"
fmt.Println(re.ReplaceAllString(str, substitution))
}