import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "stone *variant=([^\\s]*)";
final String string = "setblock ~ ~ ~ minecraft:stone variant=granite aadsdasdsad\n"
+ "execute @e[type=ArmorStand] ~ ~ ~ setblock ~ ~ ~ minecraft:stone variant=granite\n";
final String subst = "stone 1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}