# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/stone *variant=([^\s]*)/stone 1/gi;t' <<< "setblock ~ ~ ~ minecraft:stone variant=granite aadsdasdsad
execute @e[type=ArmorStand] ~ ~ ~ setblock ~ ~ ~ minecraft:stone variant=granite
"