const regex = /stone *variant=([^\s]*)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('stone *variant=([^\\s]*)', 'gi')
const str = `setblock ~ ~ ~ minecraft:stone variant=granite aadsdasdsad
execute @e[type=ArmorStand] ~ ~ ~ setblock ~ ~ ~ minecraft:stone variant=granite
`;
const subst = `stone 1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);