import Foundation
let pattern = #"\x3ci\x3e(.{1,3})\x3c\/i\x3e"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"La vida <i>es</i> bella."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}