package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\x3ci\x3e(.{1,3})\x3c\/i\x3e`)
var str = []byte(`La vida <i>es</i> bella.`)
var substitution = []byte("$1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}