import Foundation
let pattern = #"is_granted\((\[(.*?)\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
excludeIf = "expr(object.job === null or not is_granted(['VIEW', object.job]))"
excludeIf = "expr(object.job === null or not is_granted(['VIEW']))"
excludeIf = "expr(not is_granted(['VIEW_TASKS, object.site']) and not is_granted(['SITE_PERMISSION_VIEW_TASKS', object.asset.getSite()]))",
* excludeIf = "expr(not is_granted(['SITE_PERMISSION_NOTIFY_UPDATES']) and not is_granted(['OPERATIVE_PERMISSION_NOTIFY_UPDATES', object.job.getServiceProvider()]))",
$this->type = strtolower(preg_replace('/([a-z])([A-Z])/', '$1_$2', $reflection->getShortName()));
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)