import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "is_granted\\((\\[(.*?)\\])";
final String string = "excludeIf = \"expr(object.job === null or not is_granted(['VIEW', object.job]))\"\n"
+ "excludeIf = \"expr(object.job === null or not is_granted(['VIEW']))\"\n\n"
+ "excludeIf = \"expr(not is_granted(['VIEW_TASKS, object.site']) and not is_granted(['SITE_PERMISSION_VIEW_TASKS', object.asset.getSite()]))\",\n\n"
+ "* excludeIf = \"expr(not is_granted(['SITE_PERMISSION_NOTIFY_UPDATES']) and not is_granted(['OPERATIVE_PERMISSION_NOTIFY_UPDATES', object.job.getServiceProvider()]))\",\n\n"
+ "$this->type = strtolower(preg_replace('/([a-z])([A-Z])/', '$1_$2', $reflection->getShortName()));";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}