$re = '/is_granted\((\[(.*?)\])/m';
$str = 'excludeIf = "expr(object.job === null or not is_granted([\'VIEW\', object.job]))"
excludeIf = "expr(object.job === null or not is_granted([\'VIEW\']))"
excludeIf = "expr(not is_granted([\'VIEW_TASKS, object.site\']) and not is_granted([\'SITE_PERMISSION_VIEW_TASKS\', object.asset.getSite()]))",
* excludeIf = "expr(not is_granted([\'SITE_PERMISSION_NOTIFY_UPDATES\']) and not is_granted([\'OPERATIVE_PERMISSION_NOTIFY_UPDATES\', object.job.getServiceProvider()]))",
$this->type = strtolower(preg_replace(\'/([a-z])([A-Z])/\', \'$1_$2\', $reflection->getShortName()));';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);