const regex = /is_granted\((\[(.*?)\])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('is_granted\\((\\[(.*?)\\])', 'gm')
const str = `excludeIf = "expr(object.job === null or not is_granted(['VIEW', object.job]))"
excludeIf = "expr(object.job === null or not is_granted(['VIEW']))"
excludeIf = "expr(not is_granted(['VIEW_TASKS, object.site']) and not is_granted(['SITE_PERMISSION_VIEW_TASKS', object.asset.getSite()]))",
* excludeIf = "expr(not is_granted(['SITE_PERMISSION_NOTIFY_UPDATES']) and not is_granted(['OPERATIVE_PERMISSION_NOTIFY_UPDATES', object.job.getServiceProvider()]))",
\$this->type = strtolower(preg_replace('/([a-z])([A-Z])/', '\$1_\$2', \$reflection->getShortName()));`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}