using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"is_granted\((\[(.*?)\])";
string input = @"excludeIf = ""expr(object.job === null or not is_granted(['VIEW', object.job]))""
excludeIf = ""expr(object.job === null or not is_granted(['VIEW']))""
excludeIf = ""expr(not is_granted(['VIEW_TASKS, object.site']) and not is_granted(['SITE_PERMISSION_VIEW_TASKS', object.asset.getSite()]))"",
* excludeIf = ""expr(not is_granted(['SITE_PERMISSION_NOTIFY_UPDATES']) and not is_granted(['OPERATIVE_PERMISSION_NOTIFY_UPDATES', object.job.getServiceProvider()]))"",
$this->type = strtolower(preg_replace('/([a-z])([A-Z])/', '$1_$2', $reflection->getShortName()));";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}